Before entering the world of Linux, I had used just about every desktop operating system around. Despite the differences among them all, however, one thing that I eventually suffered from in each case was a kind of visual boredom. I suppose you might call it GUI fatigue. It wasn’t that I was tired of using a graphical interface; it was just that I couldn’t help but get sick of looking at the same old icons, window borders, and color schemes. Of course, there were some changes that could be made, but it just wasn’t possible to get around the basic look and feel without add-ons that demanded a price in terms of performance.

One of the features of Linux that pleased me to no end, and continues to do so, is that users can drastically change the look of things. I don’t mean just the icons and backgrounds but *everything*, including the actual window borders and controls. Add to that the variety of graphical desktop environments and window managers available for Linux, and you have a totally customizable system. Is it any wonder that there are so many more Linux desktop screenshots...
on the Web than for any other system? If you don’t believe me, just take a look at a site dedicated to Linux screenshots, http://www.lynucs.org/, and click the Screenshots link.

You may not be as fickle as I am in terms of the look and feel of your system, but you can learn to use and enjoy all the graphical customization power that Linux offers you as you work through this chapter.

**Project 8A: Creating a New User Account**

If you are reluctant to alter the look of your current setup, you can create a new user account and experiment with making the changes in this chapter when logged in to the new account. If you opt to go this route, your regular home environment will remain untouched, because look-and-feel customizations that are performed in one user account do not affect other user accounts. When you are all done with the project, you can then simply delete the new user account. Either way, it’s up to you.

**8A-1: Creating the Account**

To set up a new user account, follow these steps:

1. Select **System ➔ Administration ➔ Users and Groups**.
2. Once the Users Settings window appears, click **Add**. If asked for your password, type it into the box, and click **Authenticate**.
3. In the Create New User window that appears (Figure 8-1), type a new username in the Short Name box; I’m using `graphika` for my example. In the Name field, you can type whatever you like; I’m using `Graphics Lover`.
4. Click **OK** to add the new user. A Change User Password window will appear.
5. The Set password by hand option should be selected. Type a password for the new user; you should put numbers and letters in the password to make it more difficult to guess. Retype the password in the Confirmation box to confirm your choice, and then click **OK**.
6. You’ll be taken back to the Users Settings window (Figure 8-2). Select the new `graphika` account from the list on the left of the window, and then click the **Change** button next to where it says **Account type**.
7. In the window that appears, give yourself the ability to install software and perform other administrative tasks in the new account by selecting **Administrator**. Click **OK** to return to the main Users Settings window.
8. Click **OK**, and close the Users Settings window. The new account should be ready to use.

**NOTE**

Normally, the privilege to install software and perform other system-wide changes (Administrator) is not selected by default on new user accounts, since you probably don’t want your kids, workmates, or anyone else with their own user account on your computer installing all sorts of weird stuff and screwing up your system settings. We need it here because we’re going to be installing things, though.
To use this new account, click the power button at the far right of the top panel, and click Log Out. A countdown will appear, but you can skip that; just click the Log Out button. After a few seconds, you will be back at the login screen. Click your new username in that window, type the password for the account, and press ENTER. You will soon be at the new, untouched desktop of your just-created user.

When you log out of a user account, all the programs you have running will be closed—if you were planning to use a different account for only a few minutes, it can be annoying to have to open everything again when you get
back to the original account. Fortunately, there’s an alternative: You can temporarily *switch users*. Switching users differs from the logout/login approach, in that you remain logged in to your original account while you log in to your other account (or while someone else with an account on your computer logs in to theirs). Going this route keeps all the windows and applications you have open. These windows will not appear in the account you are switching to, but they will be there, conveniently waiting for you, when you switch back to the account from whence you came.

This is a good way to proceed if you plan to be switching back and forth between your two accounts. It is also a good approach when, say, your child needs to log in to their account for a moment to do a quick email check, burn a CD to play on the way to the beach, or print a file for school. When your child is done, you can quickly get back to what you were doing without having to reopen files, web pages, or whatever else you happened to be dealing with at the time of the switch.

You can switch users quite easily by clicking the power button on the top GNOME panel and selecting the user account you want to switch to. After a few seconds you’ll be asked for the password for the account you selected, so type it into the box, and press the ENTER key. After that, you will be at the desktop of the selected user account.

To get back to your original user account after going the switch-user route, just click the power button, click the username from which you came, and after a few seconds of darkness, a window will appear into which you must type the user password of the account you are returning to. Type your password, click **Unlock**, and you will be back at your original desktop, with everything as it was when you last saw it, open windows and all. Pretty cool.

**Project 8B: Customizing Your Desktop Environment**

Whichever user account you’ve decided to play with, you are now ready for action. By the time we get to the end of the process, you will have created a much wilder and gaudier desktop environment than you’ve ever seen before. All of this is in good fun, of course, and when you are done, you should be able to completely and confidently customize things the way you want on your own. So, let’s go.

**8B-1: Adding Emblems to Folders**

One of the coolest things about Nautilus is that it allows you to add little folder-top icons called *emblems*. These emblems can graphically remind you what each folder is for, and they’re not only for folders—you can add them to files too. The look of these emblems also changes when you change your desktop themes, so you’re in for more visual excitement later in this chapter. For now, however, let’s learn how to use them by adding one to the *Documents* folder. Open your home folder, right-click *Documents*, and then select **Properties** in the pop-up menu. When the Properties window appears, click the **Emblems**
tab, and scroll down until you see the emblem called **Personal** (Figure 8-3). Click the checkbox next to it, and then click the **Close** button. The emblem should now appear on your folder.

Now, for additional practice, try adding the Sound emblem to your **Music** folder. Just use the same steps as before, and substitute the appropriate items and entries. When you’re finished, you should have a **Music** folder that is surrounded by musical notes—one is the emblem, the other is the folder’s default icon. Not all folders have default icons, so that’s when emblems really come in handy.

### 8B-2: Setting Window Backgrounds (and Emblems Again)

Once you’ve added those two emblems, your folders should look a bit spunkier (and you’ll make those emblems look spunkier still later in the chapter). Nevertheless, the background of the Nautilus window is still plain and white. You need not stand for that if you don’t want to; you can change it as well. To do so, just go to your home window, click the **Edit** menu, and select **Backgrounds and Emblems**. The Backgrounds and Emblems window will then appear (see Figure 8-4).
From this window, you can drag any pattern into your home window, or into any other Nautilus window for that matter, and the pattern will then become the background for all your Nautilus windows. So, for experience's sake, scroll down to find the pattern called *Manila Paper*, and then drag it to the whitespace in the main pane of your home window. Once you've done that, the previously white window area will look like the wallpaper in a lawyer's office. Very nice, if you like that sort of thing. You can change it to a different background in the same way, of course, or you can go back to the default white by dragging the *Reset* swatch into the window.

**NOTE** If you prefer to use an image of your own for the Nautilus window background, you can do so quite easily. Just locate the image in a new Nautilus window, click it with both the left and right mouse buttons (or just the middle mouse button, if you have a three-button mouse), and then drag the image to any open space within the target window. When you release the buttons, select *Set as Background* in the pop-up menu that then appears.

In addition to the buttons for pattern and color swatches, there is a third button in the Backgrounds and Emblems window called *Emblems*. Clicking the Emblems button reveals all the emblems you saw in Project 8B-1, thus providing you with another way to add them to your folders. This method is far handier when adding emblems to several folders or files in the same go.

To see how this works, click the *Emblems* button. Then drag the *Camera* emblem onto your *Pictures* folder and the *People* emblem onto your *Public* folder. The selected emblems will immediately appear on those folders, adding to the growing proliferation of icons in the window.
Dressing Up the Bird

8B-3: Dolling Up the Side Pane (and Emblems Yet Again)

Now let’s change the look of the Nautilus side pane. Keeping the Backgrounds and Emblems window open (if you already closed it, open it again), click the Places menu button in the Nautilus side pane, and select Information.

You can add a different background pattern to the side pane now as well, but for practice let’s add a color instead. To do this, click the Colors button in the Backgrounds and Emblems window. The window will now be filled with swatches of color. Drag the Grapefruit swatch to your side pane, and it will turn from gray to, of all things, grapefruit (albeit a very dark and unusually colored grapefruit). You can also create a two-color gradation effect by adding yet another color. Drag the Mango swatch to the very bottom of the side pane (but still within the pane), and you should have a grapefruit-to-mango, top-to-bottom gradation within the pane. Of course, if you are not pleased with this tropical color set, you can get back to your original default gray panel by dragging the Reset swatch onto the area. When you’re done, you can close the Backgrounds and Emblems window.

The side pane of your Nautilus window provides yet a third way to work with emblems. But before I let you in on this third (and last) way, let’s add another folder to your home folder. Create a folder and name it Finances, which you can use to store files dealing with your relative worth in the modern scheme of things.

After you’ve created the new folder, go to the side pane, click the Information drop-down menu, and select Emblems. A list of emblems will appear within the side pane. Select the Money emblem, and drag it onto your Finances folder. Next, select the Plan emblem, and drag it onto the Finances folder too. Add even more emblems to it if you like—you should be able to fit about four on there before Nautilus decides to end the madness and prevent any more from being displayed. Your window should now look something like the one shown in Figure 8-5.

Once you are done, go back to the drop-down menu, and select Places to get everything back to relative normalcy again.

Even if it’s not your cup of tea, you have to admit that your Nautilus window is definitely more colorful now. You can, of course, change it to look however you want, but I’ll ask you to hold off on that a little while longer, because you are going to be doing some more playing around with it shortly.

8B-4: Changing the Desktop Background

Now that your home folder window is all gussied up (or gaudied up, depending on your aesthetic sense of things), you may think your desktop looks rather drab in comparison.

You can easily change the desktop background (often called wallpaper) by right-clicking any open space on the desktop and selecting Change Desktop Background in the pop-up menu. This will open the Appearance Preferences window, opened to the Background tab (see Figure 8-6).
Figure 8-5: Selecting emblems from the Nautilus side pane

Figure 8-6: Changing your desktop background
Installing Additional Wallpapers

As you can see if you hover your mouse over it, the default wallpaper in Ubuntu is called *Ubuntu*. If purple blobs aren’t your style, click any of the other wallpapers to immediately change the wallpaper on the desktop. There are quite a few to choose from, but maybe you’d prefer to use some images of your own. These could be photos from a digital camera, works of art you created on your computer, or just about anything you want to put there. In this case, however, you are going to venture out onto the Web to get and then install some wallpaper.

A number of sites provide free desktop wallpaper—two sites specifically geared toward Linux users are [http://www.gnome-look.org/](http://www.gnome-look.org/) and [http://art.gnome.org/](http://art.gnome.org/), but you can get wallpaper from wherever you like. Astronomy Picture of the Day ([http://apod.nasa.gov/apod/](http://apod.nasa.gov/apod/)) is a particular favorite of mine. If you want to follow along using the same bigger-than-life-Tux wallpaper that I use here, however, go directly to the wallpaper image by pointing your web browser to [http://www.taiabati.com/linux/OLDindex.php/](http://www.taiabati.com/linux/OLDindex.php/), scrolling down the page a tad to the second TUX section, and then clicking the download button next to the image size that best matches your screen. When the picture appears in the browser window, right-click it, and then select **Save Image As**. In the Save Image window, give it an easy-to-remember name (*wall_TUX-2_1024x768.png* may be exact, but it might prove a bit much to deal with after a while), or use the one I gave it, *mightyTux.png*, and click **Save**. If you prefer, you can download any wallpaper you like from wherever you like, as long as it is in a supported format, such as BMP, PNG, or JPEG. It’s all up to you.

Once you’ve downloaded your wallpaper, move it from your **Downloads** folder into your **Pictures** folder. You may want to create a **Wallpapers** subfolder to keep things better organized, but that’s up to you, too. After that, you can install the new image by going to the Background tab in the Appearance Preferences window and clicking the **Add** button. In the Add Wallpaper window that then appears, navigate to your new wallpaper, click it once to highlight it, and then click **Open**. The wallpaper will then appear highlighted in the Appearance Preferences window and will soon thereafter appear on the desktop (Figure 8-7). Once it does, click **Close** to complete the process.

**Wallpaper from Internet to Desktop—Quick and Easy**

It’s also possible to almost automatically set an image from the Web as your desktop wallpaper by right-clicking that image within your web browser and then selecting **Set As Desktop Background**. A small window will then appear, in which you can preview what the download will look like onscreen (Figure 8-8). You can also adjust the position (tiled or centered, for example) and background color for your desktop in this window. Once you’re done making adjustments, click the **Set Desktop Background** button. The image will then appear on your desktop, while the image file will be saved to a download location (your home folder, by default) with the title *Firefox_wallpaper.png*. 
You may have noticed that you can barely see the panel at the bottom of the screen in Figure 8-7. This is because the panel obscured the bottom of the new wallpaper, which irritated me. I went to the Panel Properties window by right-clicking some empty space in the bottom panel and selecting Properties in the pop-up menu. In the Panel Properties window, I clicked the Autohide button.
checkbox and then clicked Close. The autohide function works just like it does in Windows or Mac OS X—the panel stays out of view until you move your mouse into the general vicinity of where it should be. You can make the same change if you like, but that is an aesthetic matter that I will leave up to you. Ah, the sweet taste of artistic freedom.

**8B-6: Downloading and Installing the Art Manager (GNOME Art)**

Searching the Internet for wallpaper to install can in itself be a rather fun adventure, but sometimes it can also feel like quite a chore. Fortunately for you, me, and all involved in such things, there is an even easier way: the Art Manager. The Art Manager, also known as GNOME Art, is a handy application that searches the [http://art.gnome.org/](http://art.gnome.org/) site and downloads a list, with thumbnails, of all the wallpapers that are available there. It can also do this for the various window borders, controls, and icon theme sets that you can use in the following parts of this project. Using the thumbnail lists, you can easily download and install whatever you want—all without ever placing a cursor in your web browser. Needless to say, the Art Manager is decidedly cool!

Unfortunately, the Art Manager is not installed by default. However, after having gone through Chapter 6, you know how easy it is to download and install applications like the Art Manager. All you have to do is run the Ubuntu Software Center, search for `gnome-art`, and then install the Art Manager.

You can then run the Art Manager by selecting **System ➤ Preferences ➤ Art Manager**. The GNOME Art window will then appear with absolutely nothing in it. To put it to use and relieve that emptiness, select **Art ➤ Backgrounds ➤ GNOME**. (You can select **All** instead of GNOME if you like, but it will take longer to download the list of available wallpapers.)

Once you’ve made your selection, the Art Manager will begin downloading a list of all that is available for you at [http://art.gnome.org/](http://art.gnome.org/). It may seem like nothing is happening for a minute or so, but that is normal; just hang in there. It might take a few minutes to download previews of the backgrounds, but when it’s done, you will see a list of thumbnails for you to choose from (Figure 8-9).

You can now install wallpaper by scrolling down until you find one that suits your fancy, clicking it once to highlight it, and then clicking the **Install** button. The Art Manager will then download and install it. After that, open the Appearance Preferences window, and choose the wallpaper you just downloaded as your desktop wallpaper. As I said before, the Art Manager is a very handy tool to have, especially since you’ll be using it more soon within this project.
Now we get to my favorite part of this journey through the world of digital cosmetic surgery—changing the way window borders and controls look in GNOME. The procedure is really quite easy. Select System ➤ Preferences ➤ Appearance. The Appearance Preferences window will open to the Theme tab, showing you a list of the themes that are installed on your system (see Figure 8-10). The default theme in Lucid Lynx is called Ambiance, but, as you can see, there are several others.

To get the hang of things, take a look at each of the themes listed by clicking them one by one. The changes will take effect immediately. Just clicking a theme will change your window borders, controls, and even, if you take a peek in your home folder, the icons. This is especially noticeable when you click Dust Sand or New Wave.

Each theme consists of a window border, a set of controls, and a collection of icons. It’s also possible to mix and match these elements on your own. For example, let’s say that you like the subdued look and color of the controls in Dust, but you prefer the window icons in Clearlooks and the borders in DarkRoom. Well, you needn’t despair, because you can create a custom theme consisting of these three different elements.

To create your own mix-and-match theme, just click the Customize button on the Theme tab of the Appearance Preferences window. A new window will open, in which you will find five tabs: Controls, Colors, Window Border, Icons, and Pointer (Figure 8-11). From within each of these tabs, you can select the components you prefer. For now, let’s first click the Controls tab and select Dust. Then click the Window Border tab and select DarkRoom. Finally, click the Icons tab, and select GNOME.
Figure 8-10: Selecting a theme in GNOME

Figure 8-11: Creating a custom theme in Ubuntu
Now keep the Customize Theme window open, but open your home folder and take a look at what you’ve done. Hmm . . . not bad. But, perhaps you don’t really like the look of those DarkRoom window borders all that much. To find something that suits you better, click the **Window Border** tab again, go down the list, and click each entry until you see something you do like (New Wave seems to do the trick for me) and select that. Better? Now that you are satisfied, you can click the **Close** button.

You will now be back at the Appearance Preferences window, where you will notice your new theme listed with the name *Custom*. If you want to save this new combination for later use, click the **Save As** button. Doing so will open a dialog box in which you can name your theme and write a brief comment about it. So, name your theme, write a comment if you like, and then click **Save**. Your new theme will now appear in alphabetical order within the theme list under the name you chose.

Once that’s all done, your home folder window should look like that in Figure 8-12 (and take a look at your panel and Applications menu while you’re at it). Ah, très cool!

![Figure 8-12: Changing the look of your system windows](image)

**8B-8: Installing Additional Window Borders, Controls, and Icons**

If you are excited about this customization thing but you’re not satisfied with the theme choices included with the system, you can download and install still other window borders, controls, and icons. To show you how to do this, I will walk you through creating a faux Mac theme, which will look fairly similar to the standard Aqua theme of Mac OS X, as you can see in Figure 8-13.
Getting and Installing the Files You’ll Need

To get the files you’ll need to do this, take the Art Manager for another ride. Once it is up and running, select Art → Backgrounds → Other. Once the list of available wallpapers appears in the Art Manager window, scroll down until you find one called Real shoot, install it by clicking the Install button, and then select and apply it on the Background tab of the Appearance Preferences window.

**NOTE**  If the Art Manager does not automatically start downloading a list of available files when you make a selection from the Art menu, just restart the Art Manager and try again.

Next, get a set of matching application control widgets and window borders by selecting Art → Desktop Themes → Application in the Art Manager. When the list is downloaded, look for a file called Yattacier 3, and install it. In the Appearance Preferences window that then appears, select Yattacier 3 in the list on the Theme tab.

To round things up, let’s add some new icons to the mix by returning to the Art Manager and selecting Art → Desktop Themes → Icon. Once the list has finished downloading, look for and install Snow-Apple. After that, it’s basically a repeat of the previous step, but this time around, click the Icons tab in the Customize Theme window, and then select Snow Apple.
**Finishing Touches**

Well, things are certainly sort of Mac-ish now, but there is even more we can do to emphasize the effect. Open the Panel Properties window for your bottom panel by right-clicking a blank area of the panel and selecting **Properties** in the pop-up menu. In the **General** tab of that window, uncheck **Expand**, and then increase the size of the panel to about 54 pixels. When you’re done, click **Close**, and then start adding launchers for the applications you use most. You might also want to remove the Workspace Switcher and the Window List to complete the effect. Right-click the little dotted or ridged bit immediately to the left of where the names of currently open windows are displayed and choose **Remove From Panel** to get rid of the Window List, and right-click any of the set of four boxes on the bottom panel and choose **Remove From Panel** to remove the Workspace Switcher.

**NOTE**  
If you’d like a more OS X–ish Dock, plenty are available; try Avant Window Navigator, Cairo Dock, or Docky, all of which are available via the Ubuntu Software Center. You must have Visual Effects turned on (that is, set to Normal or Extra) on the Visual Effects tab of the Appearance Preferences window in order to use these.

Once you’re done, go to the top menu, and remove the two icons next to the System menu. After that, add a Window Selector applet so that you have some way to navigate through your open windows. You might also want to change the background in your home folder, since the warm tones currently there no longer match your new cooler configuration.

The transformation is now complete, but you can also add trash can and computer icons to your desktop by going on to Project 8B-10, after which your desktop should look something like mine back in Figure 8-13. You can stick with your new OS X–ish theme or switch to something else. For consistency’s sake, I will switch back to the default theme now. By the way, if you do decide to keep the faux Aqua theme, remember to click the **Save As** button in the Appearance Preferences window and give the theme a name.

**8B-9: Changing the Order of the Window Buttons**

If you’re used to Windows, you might be finding the order of the buttons at the tops of windows a little . . . weird. Instead of having your minimize, maximize, and close buttons at the top right of the window, Ubuntu puts them at the top left. I don’t mind this layout so much, but if you’re struggling with it, you’ll be glad to know it’s easy to change them to the right:

1. Press ALT-F2 to open the Run Application window.
2. Run the GNOME Configuration Editor by typing `gconf-editor` in that window and then pressing ENTER.
3. When the Configuration Editor window appears, click the small + next to `apps`, scroll down to `metacity`, and click the + next to that.
4. Click **general** in that expanded metacity section to display a set of options.
5. Scroll down to the `button_layout` option. It should be set to `close, minimize, maximize` at the moment—this gives the order of the buttons (for example, the maximize button is the third one along) and the side of the window that they appear on (for example, all three are on the left side of the colon, so the buttons will appear on the left of the window).

6. To get the buttons into the familiar Windows order, click the `value` of the `button_layout` option to start editing it. Type `minimize,maximize,close` in place of the old value.

7. Press ENTER to finish editing, and the window buttons in all your windows should switch sides immediately (as shown in Figure 8-14).

![Figure 8-14: Putting the window buttons on the right side of the window](image)

**8B-10: Placing Home and Trash Icons on the Desktop**

As you are already aware, unlike Windows, Mac OS X, or other Linux distributions, Ubuntu has a completely empty desktop upon installation. A lot of people advocate this approach because it discourages the permanent use of the desktop as a location to store files and program launchers. After all, as the argument goes, you don’t place your trash can or file cabinet on the desktop in your office, do you?

All such logic aside, many people prefer to have their trash can, hard disk, and home folder on their desktops, thank you very much. If you are one of them, as I am, here’s what you need to do:

1. Open the GNOME Configuration Editor, as you did in “Project 8B-9: Changing the Order of the Window Buttons” on page 138.

2. Click the + next to `apps`, scroll down to `nautilus`, and click the + next to that.
3. Click desktop in the nautilus section, after which the options for that item will appear in the right pane of the window (Figure 8-15).

![Figure 8-15: Adding icons to the desktop with the Configuration Editor](image)

4. Check the boxes next to the items you would like to appear on the desktop. You have four unchecked choices to choose from: computer_icon_visible, which is like the (My) Computer folder in Windows; home_icon_visible, which is for quick access to your home folder; network_icon_visible, which is to create a link to your Network folder, if you use it; and trash_icon_visible, which is for you-know-what.

5. Check any that look useful, and when you’re done, close the Configuration Editor.

**8B-11: Stretching Desktop Icons**

A pretty cool feature in the GNOME desktop is stretchable icons. This allows you to make individual desktop icons any size you want, which can be not only aesthetically pleasing but also quite functional. For example, you could stretch one of your most commonly used launchers to make it easy to locate, or you could stretch the thumbnail of a photo file so that it appears as desktop art (see Figure 8-16).

To stretch a desktop icon, right-click the icon, and select Stretch icon in the pop-up menu. Four blue squares will appear at each of the corners surrounding the icon (as shown in Figure 8-17). Just click and drag any of those squares until the icon is the size you want. Once you are done stretching, click anywhere on the desktop, and the squares will disappear. If you have second thoughts and want to revert the icon to its original size, right-click it, and choose Restore Icon’s Original Size from the menu.
Figure 8-16: Desktop icons can be stretched to any size you want.

Figure 8-17: Stretching a desktop icon

**8B-12: Doing It All Again!**

Now that you’re equipped with the necessary know-how to customize just about everything, it’s time to say goodbye to *graphika* and start work on your own user account. Click the power button at the top right of the screen, select *Log Out*, and then click the *Log Out* button to get back to the login screen. Now, log in to your usual user account and begin the task of imposing your sense of style on the place.

**Font Feathered Frenzy: Changing Your Fonts**

By now Ubuntu should be starting to feel a little more *you*; you’ve got your favorite desktop wallpaper, chosen the most appealing window borders, and added icons galore . . . so what else is there to tweak? Why, your fonts, of course! Most of the time you look at your computer screen will be spent reading, so it’s only logical to want to spruce up the text too. To get started doing this, select *System > Preferences > Appearance*, which will open the Appearance Preferences window again. Click the *Fonts* tab in that window to see the options available to you (Figure 8-18).
As you can see, you can specify font preferences in five categories: applications, documents, desktop, window titles, and the Terminal (fixed width font). To change any of these, just click the corresponding font button, and a Pick a Font window will appear. This lets you choose the font family, style, and size, and it will preview your current selection at the bottom of the window.

Once you click **OK**, the choices you make take effect immediately, so you will soon know whether you can live with them. Unlike the other aspects of customization, those choices could drive you stark raving mad. Sure, it is easy and fun to live with the gaudiest desktop imaginable, the wildest and most mismatched color scheme on the planet, and the goofiest icons ever to be seen by post-Neanderthal man, but if your font selections get too out of hand, watch out! You do have to be able to read the results, after all.

The fonts you see on your screen generally look quite smooth and clean. If you are using an LCD monitor, however, you may find that fonts will look even better if you select **Subpixel smoothing (LCDs)** in the Rendering section of the Font tab in the Appearance Preferences window. If you’re not sure whether you need to do this, just give it a try to see whether you notice any difference. GNOME applies the changes immediately upon selection, so if you keep a window with text in it open behind the preferences window, you can easily see the effect of each of your selections as you make them.
Your Ubuntu system comes with a wide variety of very usable and, at least to my eyes, rather handsome TrueType fonts. However, these tend to be a bit on the conservative side of the aesthetic spectrum, and many users will want to add a few more distinctive fonts to the system repertoire. In my own case, I had this really cool idea of writing messages to my friend in old Scandinavian runes. (Of course, my friend wet-blanketed the idea, so it all came to naught. . . .)

You probably won’t be interested in sending cryptic, runic messages to your friends, but you may want to print an award for an event using some sort of Gothic font, or you might be preparing a newsletter for the local chapter of your snail-breeders society and want to use a font that is round, bubbly, and slimy. Whatever your penchant, purpose, or desire, you will probably come to the point when you want to install some other TrueType fonts on your system, so in this project I’ll tell you how to do just that.

How you install fonts depends on who is going to use them. If you have only one user account on your machine, the easiest way is to install the fonts locally, as described in “Project 8C-2: Installing Fonts Locally” on page 144. Locally installed fonts are ones that only you or someone logged in to your user account will be able to use. On the other hand, if you have more than one user account and want the fonts to be available to all the users on your machine, you’ll need to install them globally—in this case, see “Project 8C-3: Installing TrueType Fonts Globally” on page 145.

8C-1: Getting the Font Files

The Internet is awash in free fonts. For this project, I will point you to the http://www.fontfreak.com/ site, which has a very nice collection of fonts. Once you get to the FontFreak home page, click the Fonts link under the “FREE FONTS” heading on the left side of the page. The next page will ask you whether you want to download all the free fonts on the site in one single file; click No thanks, I will download them one by one. This will lead you to the main list of free fonts; browse through the various pages until you find one that is to your liking, and then click it. Which font you download is completely up to you, but be sure to choose the PC version, not the Mac version. You can do this by clicking the Windows icon at the bottom of the font page (next to where it says Download). When the download window pops up, choose Save File and click OK to save the font as a .zip file. To follow along with this project, download a couple of fonts—I chose Aajax Surreal Freak and Accidental Presidency.

When you’ve finished downloading, drag the font files from the Downloads folder (or wherever you saved them) to your home folder so it’s easy to follow along with my instructions. Also, be sure to unzip your font files before going on to the installation steps. (Right-click each .zip file, and choose Extract Here.)
8C-2: Installing Fonts Locally

If you’re the sole user of your computer, installing fonts locally will do just fine. To get started, you need to set up your system by providing it with a location to place your fonts. You will need to do this only the very first time. Here’s what you must do:

1. Open your home folder, and, in that window, create an invisible fonts folder by selecting File ➤ Create Folder.
2. When the folder appears, name it .fonts (the period before the name means that it will be hidden).
3. Hide the new folder by clicking the Reload button. Your .fonts folder should no longer be visible. If this is the case, you can close the window—your setup was successful.

Now that everything is set up, let’s continue with this project using one of the fonts you downloaded. After you’ve decided which font to use, follow these steps:

4. Choose the unzipped font file (its name probably ends in .ttf), and copy it by right-clicking and selecting Copy.
5. Press CTRL-L, or select Go ➤ Location. This will display the location bar in Nautilus.
6. In the location bar, type ~/.fonts, and press ENTER. The ~ sign is a shortcut that means “my home folder.”
7. You should be taken to the empty .fonts folder you just created, like the one in Figure 8-19. Right-click anywhere in the folder, and select Paste to copy the font into the folder.

Now that you have installed your font, you can give it a try in one of your applications, such as OpenOffice.org Writer. (Any running applications need to be restarted before the new font will appear in that application’s font menu.)

Figure 8-19: The empty .fonts folder
**8C-3: Installing TrueType Fonts Globally**

As I mentioned earlier, the font you just installed locally can be used only when you log in under your usual username. If, however, you want to install fonts that can be used by you and anyone else who has an account on your computer, the process is slightly different and will require a little “superuser” action. You can use the other font you downloaded for this part of the project.

The folder for globally installed fonts is in root territory, so you will need to open the file browser as superuser in order to install the fonts. Superuser is another name for the root (administrative) user. It’s possible to run a program as root without switching to a different user account by using a system called sudo (more on this in Chapter 9), but since root can modify important system files, you shouldn’t run a program in sudo mode unless you absolutely must.

Here are the steps for getting your font file into the global font directory:

1. Press ALT-F2, and then type `gksudo nautilus /usr/share/fonts/truetype` into the box that appears. Click Run, and type your password if prompted.
2. A File Browser window will open. Select File ▶ Create Folder to create a new folder; call it `MyFonts`.
3. Open a normal File Browser (Nautilus) window by selecting Places ▶ Home, find the .ttf font file you want to install, and copy it (for example, by right-clicking it and selecting Copy).
4. Switch back to the truetype File Browser window, open your newly created `MyFonts` folder, and paste the font file into it.
5. Be sure to close the superuser File Browser window—leaving it open is a recipe for disaster!

**NOTE**  
The `gksudo` command in Step 1 is the graphical environment version of the non-graphical `sudo` command that you will learn to use via the command Terminal in Chapter 9.

Now you can test things by opening OpenOffice.org and looking for the font in the font menu. Remember that you will need to restart OpenOffice.org if it was already open when you installed the font.

**Project 8D: Changing Your Login Screen**

There’s always a holdout. You may have gotten your desktop and windows looking just the way you like, but the screen that’s displayed when you log in hasn’t changed one bit—it’s still the same old default theme, with the same old default background. It’s time to give it a makeover.

The login screen, also known as the greeter, is shown to everyone who has a user account on your computer, so you might want to check with others before making some of the following cosmetic changes. If you’re the only person who uses the computer, then ask yourself for permission and carry on.
8D-1: Beautifying the Login Screen

The software that displays the login screen is called GDM, and it has its own hidden user account on your computer. This might seem a little strange, but this is the way lots of Linux programs do things when they are shared between several users. What you need to do now is log in to this hidden user account and change the settings for GDM. Fortunately, it’s a pretty straightforward process and doesn’t even require you to log out of your own account:

1. Press ALT-F2 to open the Run Application window.
2. Type `gksu -u gdm dbus-launch gnome-appearance-properties` into the box, as shown in Figure 8-20.

![Figure 8-20: Typing the command into the Run Application window](image)

3. Click Run. You’ll be asked for your password, so type it, and click OK.

   **NOTE** Some extra icons might appear on your panel when you perform this step. Don’t worry, they’re harmless and will disappear when you log out and log back in again.

4. The Appearance Preferences window should appear. This Appearance Preferences window works the same way as the one you used earlier in this chapter.
5. Use the Background tab to change the wallpaper that appears behind the login screen and the Theme tab to change how the login window looks.
6. When you’re happy with your changes, click Close, and log out of your user account to get back to the login screen and inspect your changes.

   Take a look at Figure 8-21 to see what you can do. I changed the background to a delicious-looking picture of cherries and the login window to the browney-orange Human theme, for a slightly more rural feel.
Aesthetics aside, it’s time to make things a little more personal. What better way to do this than by adding a picture to your user account? Select System ➔ Preferences ➔ About Me, and when the window appears (Figure 8-22), click the button that looks like a blank face. The Select Image window will appear—choose one of the stock images from the list, or use the pane on the left of the screen to find a picture from elsewhere (a passport photo, perhaps). Now, click Open to finalize your selection, and the picture will appear next to your username in the About Me window.

While you’re there, fill out some of the other information if you like. It’s not used for very much, but as anyone who has ever possessed a permanent marker knows, it can be fun to stamp your identity all over your things. When you’re finished, close the About Me window. The picture you chose will be displayed next to your username on the login screen the next time you start the computer (as you can see in Figure 8-21).
8D-3: Logging In Automatically

While you’re tinkering with the login screen, it seems like a good idea to mention some of the other login-related options that you can change. Log in to your user account again, and select **System ▶ Administration ▶ Login Screen**. Click the **Unlock** button, and type your password to gain access to the settings in the Login Screen Settings window that appears.

If you’re the only person who uses the computer, you can save time by having your user account automatically log in when the machine starts up. Select the **Log in as** option, and choose your username from the drop-down list (it should be selected automatically). If you’re not the only user but you’re the person who uses the computer for most of the time, there’s also a setting to give other people a chance to log in before you’re logged in automatically. Check **Allow 30 seconds for anyone else to log in first**, and change the amount of time you’d like GDM to wait before logging you in.

The last option in this window (the one talking about default sessions) can be used to switch between different desktop environments. As you know, Ubuntu uses the GNOME desktop by default, but you can install others like KDE and Xfce instead. That’s a bit of a teaser for you would-be geeks out there—if you want to perform the ultimate customization and change the whole desktop environment, this is one of the settings you’re going to need to change. Changing desktops is beyond the scope of this book, though, so I’m just going to leave it there! (If you’re interested in trying a different desktop environment, you might find [https://help.ubuntu.com/community/FromUbuntuToKubuntu/](https://help.ubuntu.com/community/FromUbuntuToKubuntu/) useful.)

**NOTE** If you’re not keen on the sound that plays every time you log in, uncheck the **Play log-in sound** option in the Login Screen window.
When you’re happy with your changes, close the Login Screen Settings window, and restart your computer for the changes to take effect. Then, depending on which option you chose, either you’ll be logged in straightaway or an Automatic Login button will appear and count down the seconds until it logs you in. In the latter case, you can stop the automatic login by selecting a different username.

### Choosing a Screensaver

Screensavers used to be a must-have (and must-use) item for computer users who wanted to prevent damage (burn-in) to their monitors. Video display technology, however, has now advanced to the point where screensavers are no longer necessary. Nevertheless, screensavers are cool to look at, and plenty are available online to supplement the 15 that come installed by default. Right out of the box, the screensaver is set up to merely blank your screen after 5 minutes. However, you can also choose to have the various screensavers switch randomly every few minutes, or you can opt for a single screensaver that you especially like. You can change these settings by selecting **System > Preferences > Screensaver**, after which the Screensaver Preferences window (Figure 8-23) will appear.

**NOTE** If you’d prefer a screensaver with a more personal touch, choose the *Pictures folder* option from the list on the left of the window. This will display a slide show of all the photos in your *Pictures* folder when the screensaver is activated.

![Figure 8-23: Setting screensaver preferences](image)
Taking Screenshots

Now that you know how to make your Ubuntu desktop look a bit more like your own, you might want to share or record the results of your artistic endeavors, and taking screenshots is the way to do just that. The easiest way to go about this is by selecting **Applications ➤ Accessories ➤ Take Screenshot**.

The Screenshot application, shown in Figure 8-24, will appear. In this window you can decide whether you want to take an image of the whole screen, a section of the screen, or a selected window. You can also apply a delay before the screenshot is taken to give yourself some wiggle time. You can even add effects to your window shots, such as a drop shadow.

![Figure 8-24: Taking a screenshot in Ubuntu](image)

When you’re ready, click Take Screenshot, and a window like the one in Figure 8-25 will appear. In that window, you can name the image and decide where to save it.

![Figure 8-25: Saving a screenshot in Ubuntu](image)

If you prefer, it is also possible to take screenshots via key combinations. To take a shot of the entire screen, just press the PRINT SCREEN key. To take a shot of a single window, press ALT-PRINT SCREEN.

If you try taking screenshots of single window, you may find that the window borders refuse to appear no matter what you do. This is not a problem with the screenshot mechanism but rather a side effect of your system’s visual effects engine, Compiz, which I’ll talk about more in the next section. One
solution is to use the GIMP for your screenshot-taking chores (discussed in Chapter 13). Alternatively, you can just shut off Compiz: Select System ➤ Preferences ➤ Appearance, and click the Visual Effects tab in the Appearance Preferences window that appears. Once on that tab, select None (Figure 8-26); the change should take place almost immediately, and once it does, you can close the Appearance Preferences window and try taking your screenshot again.

![Figure 8-26: Shutting off Compiz using the Visual Effects tab](image)

### Customizing Visual Effects

Having learned how to customize your system using the more traditional tools at your disposal, it’s time to let loose and have some fun with some of the newest customization tools the Linux world has to offer. Compiz, Ubuntu’s visual effects engine, provides all sorts of wild and interesting visual effects for your desktop.

Compiz will be automatically enabled at startup only if you have a graphics card that supports its basic set of features. An easy way to tell whether Compiz has kicked in on your machine is to open any window (your home folder, for example) and then check to see whether that window has a drop shadow (see Figure 8-27 for an example). If it does, Compiz is at work.
The effects that are active by default are really the tip of the iceberg. Depending on the capabilities of your graphics card, you will get the drop shadows and a few other bells and whistles, such as cooler window-opening transitions, but that’s about it . . . on the surface, at any rate. If you like, you can kick the effects up a notch by selecting **System ➤ Preferences ➤ Appearance**, clicking the **Visual Effects** tab of the Preferences window, and finally selecting **Extra** in that tab.

I should warn you not to be freaked out at first when you try to move your windows and they start wiggling like jelly—that’s one of the additional effects (Wobbly Windows).

Whatever the hardware capabilities of your system, if you really want to take control of all that Compiz has to offer, it is worth your while to install the CompizConfig Settings Manager (Figure 8-28), which you can get via the Ubuntu Software Center (search for **Advanced Desktop Effects Settings** and install it). Once it’s installed, you can run it by selecting **System ➤ Preferences ➤ CompizConfig Settings Manager**.

Once the CompizConfig Settings Manager is installed, you can see everything Compiz is capable of doing, and you can pick and choose from those features as you see fit. Although most of what Compiz has to offer is essentially eye-candy (which is what this chapter is all about, after all), there are some functional utilities and extras. A favorite of mine is the Annotate tool, which allows you to write all over your screen while making presentations, brainstorming, or just flipping out (shown in Figure 8-29).

To activate the Annotate tool—or any other Compiz feature—open the CompizConfig Settings Manager, and check the box next to its name. To figure out how to actually use what you’ve enabled, click the name of the feature. This will open a tab showing its settings, including the keystrokes needed to initiate that feature (Figure 8-30).
NOTE Some of the keys used for the default Compiz shortcuts may seem unfamiliar; of these, the most commonly used ones are the Super key (typically the Windows key on your keyboard) and Button 1 (usually your left mouse button).

Figure 8-28: Taking control of Compiz’s special effects

Figure 8-29: Compiz’s Annotate tool in action
Figure 8-30: Almost every Compiz feature has its own settings.

You can also edit the various keystroke combinations by clicking the button where the current keystroke combination is shown and then making your new choices in the Edit window that appears (Figure 8-31). When you’re done with the settings for an individual feature, click the Back button in the lower-left corner of the CompizConfig Settings Manager window to go back to the main screen.

Figure 8-31: Changing the keystroke combination used to initiate a Compiz feature