GIMP for Photography, Special Effects, and Design

As a feature-rich, free alternative to Adobe Photoshop, GIMP is one of the world’s most popular open source projects. The latest version of GIMP brings long-anticipated improvements and powerful new tools to make graphic design and photo manipulation even easier—but it’s still a notoriously challenging program.

The Artist’s Guide to GIMP teaches you how to use GIMP without a tedious list of menu paths and options. Instead, as you follow along with Michael J. Hammel’s step-by-step instructions, you’ll learn to produce professional-looking advertisements, apply impressive photographic effects, and design cool logos and text effects. These extensively illustrated tutorials are perfect for hands-on learning or as templates for your own artistic experiments.

After a crash course in GIMP’s core tools like brushes, patterns, selections, layers, modes, and masks, you’ll learn:

- **Photographic techniques** to clean up blemishes and dust, create sepia-toned antique images, swap colors, produce motion blur, alter depth of field, simulate a tilt-shift, and fix rips in an old photo.
- **Web design techniques** to create navigation tabs, icons, fancy buttons, backgrounds, and borders.
- **Type effects** to create depth, perspective shadows, metallic and distressed text, and neon and graffiti lettering.
- **Advertising effects** to produce movie posters and package designs; simulate clouds, cracks, cloth, and underwater effects; and create specialized lighting.

Whether you’re new to GIMP or you’ve been playing with this powerful software for years, you’ll be inspired by the original art, creative photo manipulations, and numerous tips for designers.

As a full-featured, free alternative to Adobe Photoshop, GIMP is one of the world’s most popular open source projects. The latest version of GIMP brings long-anticipated improvements and powerful new tools to make graphic design and photo manipulation even easier—but it’s still a notoriously challenging program.

The Artist’s Guide to GIMP teaches you how to use GIMP without a tedious list of menu paths and options. Instead, as you follow along with Michael J. Hammel’s step-by-step instructions, you’ll learn to produce professional-looking advertisements, apply impressive photographic effects, and design cool logos and text effects. These extensively illustrated tutorials are perfect for hands-on learning or as templates for your own artistic experiments.

After a crash course in GIMP’s core tools like brushes, patterns, selections, layers, modes, and masks, you’ll learn:

- **Photographic techniques** to clean up blemishes and dust, create sepia-toned antique images, swap colors, produce motion blur, alter depth of field, simulate a tilt-shift, and fix rips in an old photo.
- **Web design techniques** to create navigation tabs, icons, fancy buttons, backgrounds, and borders.
- **Type effects** to create depth, perspective shadows, metallic and distressed text, and neon and graffiti lettering.
- **Advertising effects** to produce movie posters and package designs; simulate clouds, cracks, cloth, and underwater effects; and create specialized lighting.

Whether you’re new to GIMP or you’ve been playing with this powerful software for years, you’ll be inspired by the original art, creative photo manipulations, and numerous tips for designers.

About the author:
Michael J. Hammel has been involved with GIMP since version 0.54 and was a contributor to the early development of the program. Hammel wrote a column on GIMP for Linux Format for three years and is the author of The Artist’s Guide to the GIMP and Essential GIMP for Web Professionals. He is an embedded software engineer living in Colorado Springs.
This effect creates a ghostly figure wreathed in flame—a demon, an angel, a ghost, or an ifrit depending on your perspective. I simply call her the Fire Girl. The process for creating this effect can be reduced to these basic steps:

1. Isolate the girl from the background.
2. Edge-detect the girl on multiple layers.
3. Add and blend ornamental elements.
4. Blend to remove excess details.
5. Add flame and coloring.
6. Add background emblem.

Throughout the project, you’ll find that flames aren’t just components of the image but are also used for coloring. The easy way of using a flame to color a layer is to first desaturate the layer, and then add a flame layer above and set the flame layer mode to whatever “looks right.” However, if you place an image below a flame layer, the black region around the flame may block that lower layer from being visible, depending on the flame layer’s blend mode. To avoid this, you’ll use layer masks on flame layers or simply copy and paste flames, taking care to omit the black backgrounds from your source image.

Note that even if you follow this tutorial exactly, you won’t produce the same image. The steps allow for too many variations, especially when creating the crown of flames. Don’t be discouraged if your first attempt is less than ideal. I went through seven different designs before settling on this process. And the first four or five of those are, to be kind to myself, not something I’d ever show in public. I won’t even show them to my wife.

The tutorial’s process starts with a large canvas (2350 × 2033) to produce a print-ready design. To reduce memory and CPU requirements, you can scale the stock images down by 50 percent before starting.

Several stock images are used in this project, but the end result bears little resemblance to those originals.

### Isolating the Girl from the Background

The first step in this project is to isolate the girl from her background. This is done primarily because the background in the source image for the girl is not required for the project, and its color may cause problems when mixed with other layers. Isolating the girl will also allow background elements to be added behind her.

1. Desaturate the source image (Colors ➤ Desaturate) and select the Luminosity option. The source image has a yellowish tint when converted from its original color space (provided in the...
image when downloaded from the stock image website) to the color-managed display in GIMP. The yellow tint converts to a bright white when the Luminosity option is selected in the Desaturate dialog. If you aren’t using a color-managed display, it may not matter which setting you choose in the Desaturate dialog.

2. Use **Select By Color**. In the Tool Options dialog, set the Threshold to **50** and click the white background. This will select all of the background, a little of the hair, and some of the face and neck.

3. Switch to **Quick Mask** mode and paint out the white areas over the girl with a black foreground color and a large brush. Switch off Quick Mask mode and invert the selection.

4. Copy and paste the selection to a new layer and name it **Girl**. Fit the new layer to the canvas using **Layer ▶ Layer to Image Size** so that any modifications made to the girl won’t be restricted by the size of the layer.

5. In the original layer (which is titled Background by default), use **CTRL-A** to select the entire layer and then drag the black foreground color into the canvas to fill that layer with black.

6. Now it’s time to get rid of the hair with a layer mask. Add a white layer mask to the Girl layer. Starting with a large brush and switching to smaller brushes, paint with black in the layer mask until most of the hair is removed. Leave a small amount of hair to provide an additional visual feature when using the edge-detect filters. Turn off the Girl layer visibility so it doesn’t interfere with the next steps. Apply the layer mask (**Layer ▶ Mask ▶ Apply Layer Mask**).

Painting with black in the Quick Mask colors the white areas in the face and neck, effectively taking those areas out of the selection. The poor selection around the hair doesn’t matter—you’ll get rid of the hair next.

Hair on the face will be cleaned up later. Leave just a bit of hair around the top of the head.
Edge-Detecting the Girl to Create Multiple Layers

The next step in this project is to create detailed outlines of the girl using edge detection filters. Two such filters will be used: Filters ➤ Edge-Detect ➤ Edge and Filters ➤ Edge-Detect ➤ Neon. These produce similar results, which will be combined using layer modes.

1. Duplicate the Girl layer, make the duplicate visible in the Layers dialog, and name the duplicate Edge Detect. Open the Edge-Detect filter and select the Prewitt compass algorithm. The choice of algorithm is based on the preview. Choose the algorithm that shows the most detail. Apply the filter to the layer and set the layer mode to Screen.

2. Duplicate the Girl layer and turn on the duplicate layer visibility again, this time naming the new layer Neon Detect. Move this layer to the top of the layer stack.

3. Invert the colors (Colors ➤ Invert) in this layer, and then apply the Neon edge-detect filter. Set the layer mode to Screen. Duplicate this layer, giving three layers of edge detection above the Girl layer.

Zooming in on this, you may find some strands of hair that were missed with the mask previously applied to the Girl layer. These can be left, or they can be removed with the eraser. If the eraser is used, it will probably need to be applied to the same area on each of the three edge-detect layers.

Blending in Ornamental Elements

Now it’s time to ornament the girl. The best places to find these types of designs are on ornate picture frames and building architecture. This project got stuck with picture frames only because I couldn’t find any really good photos of Victorian architecture.

There are two ornamental pieces added to the design: one on the forehead and one around the neck. The former comes from a mostly rectangular frame while the latter comes from an oval frame.

1. Start with an image of a rectangular frame and desaturate it. (Choose a frame that’s easy to isolate, like this one with a solid color background.)

2. Use the Fuzzy Select tool with the Threshold set to 50. Click once outside the frame, and then hold down the shift key and click inside to create a complete selection of the background. Grow this by 1 pixel (something I nearly always do to avoid light-colored pixels along the edge of the selected object) and then invert the selection.

3. Copy and paste the frame into the working canvas as a new layer at the top of the layer stack. Name it Ornamental: Forehead. The layer mode should be set to Normal.

4. Scale, rotate, and position the Ornamental: Forehead layer over the girl’s face. Use a layer mask to remove the unwanted sides and edges of the frame. Duplicate the layer and set the duplicate layer mode to Dodge. Dodging the copy over a desaturated normal mode original enhances contrast (in this case, it makes our girl shinier).
The scale, rotate, and position process takes experimentation. Rotation and scaling are easier if you set the Tool Options Preview to Grid instead of Image.

The ornament around the neck is created the same way, albeit starting with a different frame. The rotation, size, and position will be different than in the Forehead version, not to mention being masked differently. In this example, the bottom edge of the frame is kept, while the rest is masked out.

1. Copy and paste another frame selection as a new layer. The layer name for this copy is Ornamental: Neck. Rotate, size, position, and mask as appropriate. Finally, the mask is added to keep just the (now) bottom portion of the frame.
2. Duplicate the neck layer and change the layer mode to Dodge.

Note that in this example, the actual frame images were smaller than the main image window but larger than the girl. This required shrinking the size of the frames. Had they been too small you could have scaled them up. This is seldom done because the scaled image quickly becomes pixelated. However, in this case the pixelation is hardly noticeable because of the weakly identifiable shapes (the ornate structure has no discernible objects—it's just wavy lines). Additionally, using multiple copies of a frame layer and blending layer modes hides some of the pixelation, and, later, coloring with flames hides even more. The sheer size of this image also hides some of that pixelation when working onscreen. Large prints, however, would likely show the pixelation. Therefore, any prints for this size image when layers were scaled up would need to be no larger than the size of a magazine or book page.

Later you may find that colorizing with the flames leaves the ornamental layers rather bland. If that happens, try returning to these steps and using the frames without desaturating them.

Blending to Remove Excess Details

The ornaments may not hide as much hair or facial blemishes as desired. To remove these from the girl’s face, use the Eraser and Smudge tools along with a drawing pad. If you don’t have a drawing pad, just use a smaller brush and vary the opacity manually.
**NOTE** Drawing pads are flat panel input devices, some with built-in displays, which work with a stylus. Drawing on the pad with the stylus moves the cursor on the monitor much like moving a mouse. These pads are typically connected to the computer via a serial or USB port. Many artists find it easier to use drawing pads for design work than a standard mouse. Popular makers of drawing pads include Wacom, Genius, Adesso, and Aiptek.

Smudging in the edge-detect layers is possible (white and black, when smudged, give shades of gray), but it would be better to leave some of the line details in the face. To accomplish that, use the Eraser with a grunge brush and set Brush Dynamics to increase Opacity, Hardness, and Size when pressure is applied using the drawing pad (or manually with different strokes).

1. Apply the eraser to each edge-detect layer, starting with the topmost of these three layers. Do only a small amount on each layer before moving to the next, rotating back to the top and repeating. The goal is to try to keep as much of the detail as possible while losing obvious blemishes in the girl’s face.

2. Turn off the visibility of the three edge-detect layers and turn on the visibility of the **Girl** layer. Enable the **Lock Alpha Channel** option for the Girl layer.

3. Choose the **Smudge** tool, using any appropriate brush to blend the hair out of this layer. Try to keep the lighting smooth across the cheek by clicking in lighter areas first (the cheek) and dragging into darker areas (the hair). Smudge the neck and clothing as well.

4. With the layer **Lock** enabled, you don’t have to be careful not to smudge outside the girl.

5. When completed, turn on the visibility of the edge-detect layers.

---

Notice that the hair over the ear is not touched. That only enhances the random nature of the flames added later.
Adding Flame Coloring

1. Choose the Girl layer from the Layers dialog. Open the Colorize dialog and set the Hue, Saturation, and Lightness to 30, 90, and −30, respectively.

2. Open and copy in a roaring fire image (flame and black background) as a new layer at the top of the layer stack. Scale the layer so the flame fits completely over the girl, and then crop the layer to fit the image (Layer ▶ Layer to Image Size). Set the layer mode to Hard Light. This brings out the red in the flame.

3. The layer may not span the width of the image. In that case, you can end up with a white band filling the extra space. If this happens, use the Fuzzy Select tool, grow by 1, and fill the selection with black.

4. At this point the flames obscure the girl’s face. You have several options: leave it alone (because you think this looks cool), use the smudge tool, or add a layer mask on the flame layer to let the face and ornaments show through.

Creating the Crown of Flames

The process for creating the crown is simple, but you’ll likely need a few attempts to get it right.

1. Start with a flame image like the one shown here—a flame, not a roaring fire. Copy just the flame (not the black background) into the working canvas. Name the new layer Flame Hat. Scale this layer to fit from the girl’s forehead to the top of the image.

2. Duplicate this layer, flip it horizontally, and position the duplicate close to the original Flame Hat layer.

3. Use a mask on the Flame Hat copy layer to blend the flames together as necessary. Then merge the two layers by selecting the top layer of the two and choosing Layer ▶ Merge Down.

4. Move the merged layer to the middle of the image window and size the layer to the image again. Now you have the basic flame-hat frame with space around it to create the flame swirls.

A large, hard-edged brush (Round 101, sized to 150 pixels) was used with the Airbrush to lightly remove the flame over the girl’s face.

The stock flame image makes a good hat on its own, but I found its downward-pointing highlights a bit depressing. So a little warping magic will be applied next.
5. Use the IWarp filter (Filters ▶ Distorts ▶ IWarp) to create the flame swirls. Swirl the left side of the hat using the Swirl CW mode, and swirl the right side of the hat using the Swirl CCW mode. Choose one or more spots on each side that would make good swirls. Click (never drag) in the preview in various places to create the swirls with nearly uniform appearance. Clicking and holding also works, but hold for a short amount of time or the swirl gets too big.

6. Experiment with the Deform radius and Deform amount, as well as where to click in the preview. If the preview gets messed up or you just don’t like it, hit Reset and try again. Remember: this step takes a lot of experimentation!

7. After applying the IWarp settings to the Flame Hat layer, position and rotate the hat over the girl’s head. Set the layer mode to Screen. Add another copy of the roaring fire from the coloring step above this layer, scaled so the whole flame fits inside the hat. Set the layer mode for the roaring fire layer to Screen. Use a layer mask to blend it into the hat.

**Further Exploration**

To add a sort of Mayan feel to this project, select the Mandala brush from the GIMP Paint Shop collection (or any suitable oval icon converted to a brush). Use the Paintbrush tool and increase the scale of the brush until a single brush click is roughly 3/4 the size of the image window. Add a transparent layer above the Background layer, set the foreground color to white, and click once in the new layer.

**NOTE**  
GIMP Paint Shop is an add-on package of brushes, patterns, palettes, and tool presets that allows users to simulate specific drawing and painting tools and techniques, such as watercolor, blue ink pens, and charcoal. GIMP Paint Shop is available on the web at http://code.google.com/p/gps-gimp-paint-studio/.

Duplicating the flame layers and masking out different parts, and then setting different layer modes can also affect the final version of your artwork. Don’t be afraid to experiment—just be sure to save your work periodically!

Above the Mandala imprint layer, add the roaring fire image in a new layer. Scale the fire to cover most of the imprint and set the layer mode to Multiply.

To enhance the fire hat, add a fire emblem. The emblem can be a stock image or a handmade image copied, pasted, scaled, rotated, and positioned over the hat. Piece of cake compared to that business with the IWarp swirls, right?